Options field in form passing extra characters

I have my form connected to my CRM so that I can map the field responses as my user moves through the funnel.

However, it seems that some incompatibility between the CRM and how the values are being passed is causing extra characters being passed. I guess this has to do with the format of the body, the array with the options or the way the json data is being passed.

Here is that is being pasted into my CRM fields:
Screenshot 2024-07-04 at 15.08.02
As you can see, all of the options fields have the brackets and quotes in it.

You can also see the details of the request here:

Is there any way to fix this? Thank you!

Hey there - can you please share the account, form & fields, and API you’re using in here?

Hi Eri,

Account/team name: Upfundingcapital
User: javier@upfundingcapital.com
Form ID: 6nsX0P
Field IDs (for the example above):

The API connectors is 02. DS POST - Update initial fields

The “Financed before” and “Has bank account” are a bit of a hack I did. I wanted to have the button options horizontally not vertically, but since I don’t think this could be done I created two Button groups for each option with just one option. So although they correspond to the same question they have different field IDs*

Currently the body request is passing these as:

  "Financed before no": "{{past-financing-no}}",
  "Financed before yes": "{{past-financing-yes}}",
  "Has biz bank acct no": "{{bank-acct-no}}",
  "Has biz bank acct yes": "{{bank-acct-yes}}"

But the other option that could be more clean if we could make it work is (this is how the screenshot in my previous messaged was mapped, but not the current content of the Request body):

  "Financed before": {
    "no": "{{past-financing-no}}",
    "yes": "{{past-financing-yes}}"
  "time-in-business": "{{time-in-business}}",
  "Has biz bank acct": {
    "no": "{{bank-acct-no}}",
    "yes": "{{bank-acct-yes}}"

Let me know if this helps, if there is anything else you need, or if the above is not clear please. Thank you!

We made an update so it should be passed as the direct value in 20 minutes or so

Hi Peter,
I tried the form and it seems I am getting a 500 server error when that request is being sent:

It is a bit strange because the other connector APIs are working and passing the information normally as before.

However, about the values being passed between brackets, I have another input field coming from a button group later in the form (you can see it here Solicita Fondos con Upfunding - Upfunding Capital)
and this does not seem to be passing correctly either:

Let me know if you need any more information please. Thanks for your support.

Can you try again now?

Hey Peter,

The server error seems to be fixed. The data is passing a bit differently but still not properly:

Before: [\"$20k to 49k"\]
Now: ["$20k to 49k"]

Details of the Request:

Sorry - please try one more time in half an hour

This is working now. Thank you Peter!