"This site can't provide a secure connection" Error

“This site cant provide a secure connection
form.feathery.io sent an invalid response.
ERR_SSL_PROTOCOL_ERROR”

I keep getting this error code from Google when I try to load my form through a qr code. whenever I run my own test with my phone the site will never load. I have tried clearing cookies /cache and I have tried using incognito browser and also I have tried using safari but with no luck. I feel like the problem is with my phone and not the site but I cant really tell.

when I tried using aloha browser it told me try and load the page using a VPN and it did work. Does anybody understand what is happening here and if my the people using this form will have trouble loading the form?

We’re taking a look here

@tloquatt Hi there! Could you please verify a few items:

  1. What OS are you using (mobile/desktop)
  2. When you see the error, what is the complete URL in the address bar?
  3. If you try to open the form link directly in your mobile/desktop browser, do you get the same error? (Also, what is the complete link that you tried for this step?)
  4. What area are you making this network request from?
  5. Where did you create the QR code? What is the link you generated the QR code for?
  1. I have tried with all my devices. A 2018 Macbook pro, A 2015 Macbook pro, an Iphone X and an Iphone 7 using both chrome and safari.

  2. The complete URL is always the same no matter the browser
    NCS Flatware Form

  3. I have tried opening from the QR code, from the link at QR Chimp where the QR code was created, and directly from feathery. I have also tried in incognito mode in chrome and safari. Half the time it works from the computer browser putting the direct link half the time it does not work. It never works from the QR scan. The complete link is always the same no matter where I am opening it. (posted above)

  4. I am in Georgia, USA

  5. I created the QR code at QR chimp. The url generated is NCS Flatware Form. This link always forwards correctly to the featherly form url (posted above)

Thank you for looking at this problem.

I guess my URL’s were converted to hyperlinks by the site in my last post. you can hover on them and see the actually URL’s

UPDATE: For some reason when I turn my wifi off and use data it is working. So maybe the problem is on my side.

Hi there,

Thank you for providing this information. Since this issue happens on your WiFi network, could you tell us what ISP you have? Also, do you use a VPN? If so, which VPN?

Thanks You,
The Feathery Team