Google Sheet Update Criteria Broken/Unclear

Google sheets update row criteria drop down select appears to be broken. When trying to select a row to use as the update criteria, it fails to load the column header names in the dropdown.


In addition, it appears to not be updating or adding rows when the “step loaded” is being triggered when I test it. No additional rows are being added to my spreadsheet, but the results are being updated in the “results” tab in feathery.

cc: @AK-Rollout to help with the loading column header names in the dropdown

The step loaded trigger will only run once per submission when the step is first loaded. If you want to constantly run when updating the same submission, data received would be a better trigger

Thanks Peter, I made the change as you suggested but now there is a new problem - it has deleted my header row from my google sheet, which consequently breaks my field to column mapping. I can restore it just fine, but it appears there some kind of bug in the sheets integration that’s deleting the header row.

Hey Kevin, we are looking into this cc: @AK-Rollout

Hi Kevin,
We took a look at your Gooogle Sheets Integration. The Columns of the spreadsheet were not showing likely because of some issue with page refresh.
I unchecked and rechecked the update checkbox and now the column names are showing.

Let me know if you are still facing this issue.

Hi Kevin,
To clarify further:
On your integration you should now be able to see the column names in the dropdown. We accessed your integration form and checked the that column names are now showing. Above is the screenshot. Please let me know if that is still not the case.
Once the column names are showing and you select one column name, this column’s value will be used as the search criterion in the google sheet.
Also, the header row won’t be deleted anymore as you would have selected one of the column names

Unfortunately this is still happening. It appears that whenever data is received, feathery is deleting my first header row. I just tested this by restoring my header row with the column names in my google sheet, then filling out one step of my form. The header row had been deleted again.

I changed nothing in feathery about the google sheet integration but if you go in you’ll see the integration has lost all of the column mappings.

Can you please confirm that you see the column names as in this video?

Yes that part works now but the issue is that I can’t submit the form without it overwriting my header row in my integrated google sheet. That results in the column header mappings getting deleted.

Hi Kevin,
Thanks for your patience.
We reproduced this error. It happens when you check the ‘update existing row’ box but do not specify the column name in the update criterion.

Below is your form:

If the column name is saved, then running the automation will not overwrite the header. But, there is a bug here with page refresh. When you refresh the page, the column name that was saved does not show up. So, rerunning the automation will still overwrite the header.
Please give us a few hours to fix this issue.
While we are fixing this, can you please run the automation one more time with the column name saved.

Thanks Chaltanya, I’ve removed the update criteria for now and removed the ability for users to edit their applications in order to avoid this bug for the time being. I reset the google sheets integration and re-mapped my columns to the form fields which now works and receives data in the sheet just fine.